PKGBUILD 558 B

123456789101112131415161718192021222324
  1. pkgname=calcpkg
  2. pkgver=20131230
  3. pkgver() {
  4. cd "$srcdir/$pkgname"
  5. if git describe --tags > /dev/null 2>&1;then
  6. git describe --tags --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g';
  7. else
  8. date +%Y%m%d;
  9. fi;}
  10. pkgrel=1
  11. pkgdesc='calcpkg is a command line tool for downloading TI calculator software from www.ticalc.org'
  12. license=()
  13. url=
  14. arch=('any')
  15. source=("git+https://github.com/TC01/calcpkg.git")
  16. build() {
  17. cd "$srcdir/$pkgname"
  18. python2 setup.py build;
  19. }
  20. package() {
  21. cd "$srcdir/$pkgname"
  22. python2 setup.py install --prefix=$pkgdir;
  23. }
  24. md5sums=('SKIP')