123456789101112131415161718192021222324252627282930 |
- # Maintainer: Nathaniel van Diepen <[email protected]>
- pkgname=calcpkg
- pkgver=20131230
- url='https://github.com/TC01/calcpkg'
- pkgver() {
- cd "$srcdir/$pkgname"
- if git describe --tags > /dev/null 2>&1;then
- git describe --tags --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g';
- else
- date +%Y%m%d;
- fi;}
- pkgrel=4
- makedepends=('git')
- pkgdesc='A command line tool for downloading TI calculator software from www.ticalc.org'
- license=('MIT')
- arch=('any')
- source=("git+https://github.com/TC01/calcpkg.git" "LICENSE")
- build() {
- cd "$srcdir/$pkgname"
- python2 setup.py build;
- }
- package() {
- mkdir -p "$pkgdir/$pkgname/usr/lib/python2.7/site-packages";
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- export PYTHONUSERBASE=$pkgdir/usr;
- cd "$srcdir/$pkgname"
- python2 setup.py install --user;
- }
- md5sums=('SKIP' 'SKIP')
|