PKGBUILD 864 B

1234567891011121314151617181920212223242526272829
  1. pkgname=pacman-repo
  2. pkgver=r8.3b97d0b
  3. pkgver() {
  4. cd "$srcdir/$pkgname";
  5. printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
  6. }
  7. pkgrel=1
  8. url='https://eeems.codes/Eeems/pacman-repo'
  9. pkgdesc="A tool for automating the creation and maintenance of pacman repos"
  10. arch=('any')
  11. source=("git+https://eeems.codes/Eeems/pacman-repo.git")
  12. md5sums=('SKIP')
  13. depends=('python-pyaml' 'python-blessings' 'python-psutil' 'pyalpm')
  14. makedepends=('git' 'nuitka')
  15. license=('MIT')
  16. # prepare() {}
  17. build() {
  18. cd "$srcdir/$pkgname";
  19. nuitka3 \
  20. --show-progress \
  21. --follow-imports \
  22. --include-module pacman_repo \
  23. pacman_repo/command_line.py
  24. }
  25. package() {
  26. cd "$srcdir/$pkgname";
  27. install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
  28. install -D command_line.bin "$pkgdir/usr/bin/pacman-repo"
  29. }