PKGBUILD 1.0 KB

123456789101112131415161718192021222324252627282930313233343536
  1. pkgname=pacman-repo
  2. pkgver=r3.4985117
  3. pkgver() {
  4. cd "$srcdir/$pkgname";
  5. printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
  6. }
  7. pkgrel=1
  8. url='https://eeems.codes/Eeems/pacman-repo'
  9. pkgdesc="A tool for automating the creation and maintenance of pacman repos"
  10. arch=('any')
  11. source=("git+https://eeems.codes/Eeems/pacman-repo.git")
  12. md5sums=('SKIP')
  13. depends=('python' 'python-yaml')
  14. makedepends=('git' 'nuitka')
  15. license=('MIT')
  16. # prepare() {}
  17. build() {
  18. cd "$srcdir/$pkgname";
  19. nuitka3 \
  20. --show-progress \
  21. --follow-imports \
  22. --include-package=pacman_repo \
  23. --module pacman_repo
  24. nuitka3 \
  25. --show-progress \
  26. --follow-imports \
  27. pacman_repo/command_line.py
  28. # --remove-output \
  29. # -o pacman-repo \
  30. }
  31. package() {
  32. cd "$srcdir/$pkgname";
  33. install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
  34. install -D command_line.bin "$pkgdir/usr/bin/pacman-repo"
  35. install -D pacman_repo.so "$pkgdir/usr/lib/python3.8/site-packages/pacman_repo.so"
  36. }