1234567891011121314151617181920212223242526272829 |
- pkgname=pacman-repo
- pkgver=r8.3b97d0b
- pkgver() {
- cd "$srcdir/$pkgname";
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- }
- pkgrel=1
- url='https://eeems.codes/Eeems/pacman-repo'
- pkgdesc="A tool for automating the creation and maintenance of pacman repos"
- arch=('any')
- source=("git+https://eeems.codes/Eeems/pacman-repo.git")
- md5sums=('SKIP')
- depends=('python-pyaml' 'python-blessings' 'python-psutil' 'pyalpm')
- makedepends=('git' 'nuitka')
- license=('MIT')
- # prepare() {}
- build() {
- cd "$srcdir/$pkgname";
- nuitka3 \
- --show-progress \
- --follow-imports \
- --include-module pacman_repo \
- pacman_repo/command_line.py
- }
- package() {
- cd "$srcdir/$pkgname";
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D command_line.bin "$pkgdir/usr/bin/pacman-repo"
- }
|