# Maintainer: Nathaniel van Diepen <eeems@eeems.codes>

pkgname=system-msg
pkgver=v2.4.r0.g9aeb780
url="https://github.com/Eeems/system-msg"
pkgver() {
        cd "$srcdir/$pkgname"
        if git describe --tags > /dev/null 2>&1;then
                git describe --tags --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g';
        else
                date +%Y%m%d;
        fi;
}
pkgrel=2
pkgdesc="Allows admins to easily add messages to be displayed at boot without having to edit files."
arch=('any')
source=("git+https://github.com/Eeems/system-msg.git")
build() {
        cd "$srcdir/$pkgname"
        make
}
package() {
        cd "$srcdir/$pkgname"
        make DESTDIR="${pkgdir}" install
}
md5sums=('SKIP')